How to solve the "Exchange Server doesn't support the requested version" error

Last update:
Created :
Written by Thomas Speekenbrink

Overview:

When creating a Nebula profile and after filling in your (Hosted) Exchange credentials, it might show the error: Exchange Server doesn't support the requested version.

How to:

This error means you have an outdated version of Exchange. Please check if you have Exchange 2010 SP2 as a minimum (version 14.2.247.5).

Check all Exchange Server versions here.

Check all Nebula Synchronizer System requirements here.