System Requirements - Label and Print Toolbox

Last update:
Created :
Written by Thomas Speekenbrink

Product Page / More Information:

Label and Print Toolbox @ CRMPlaza

To use the Label and Print Toolbox application the following requirements have to be met:

Operating System:
  • MS Windows XP Professional SP3
  • MS Windows Vista Business
  • MS Windows Vista Ultimate
  • MS Windows 7
  • MS Windows 8.x
  • MS Windows 10
 
SuperOffice Versions:
  • SuperOffice 6.3 (Windows)
  • SuperOffice 7.0 or higher (Windows)

Microsoft Office versions:
  • MS Office 2003
  • MS Office 2007
  • MS Office 2010
  • MS Office 2013
  • MS Office 2016

Important notice!
The Label and Print Toolbox uses the new Dymo Label Printer software version 8.x.
 
This new software also works for older models of the Dymo LabelWriter devices. Navigate to the Dymo web site to download the new Dymo Label printer software.

WARNING
All the printer drivers from Dymo are NOT ready for hosted environments like CITRIX, Terminal Server, SaaS and other hosted network environments

Microsoft .Net Framework version 4.0 (x86-x64)
(if not installed, the installer will install it automatically, or it can be downloaded by visiting the following link: http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718