Created :
Written by Support InfoBridge
Overview
The InfoBridge Synchronizer service is started, all looks normal and after a while the service is stopped. In the event viewer you see the the following error message:
Unable to open database connection: ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
Unable to open database connection: ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
Cause
The required information to run the Synchronizer service like ODBC connection, username etc are not specified or in the wrong Appdata folder
How to
First check if the correct SuperOffice settings have been filled in in the Synchronizer admin
The Synchronizer was probably installed under the Administrator account. This means that after saving the Service Options in the sync admin, the output file was saved in the Administrator's Local Roaming folder (appdata).
If the above is true, copy the service.ini file from the local roaming administrator folder into the folder of the user running the InfoBridge Service and try again
Path: C:\Users\[User]\AppData\Roaming\InfoBridge SuperOffice Exchange Synchronizer EWS
- Start the Synchronizer Admin
- Select the Service Options from the dropdown list
- Fill in the required information or click the button Retrieve settings from SuperOffice
- Confirm the settings & click Apply this setting for all the users
- Close the Synchronizer Admin
- Restart the Infobridge Synchronizer service in services.msc
The Synchronizer was probably installed under the Administrator account. This means that after saving the Service Options in the sync admin, the output file was saved in the Administrator's Local Roaming folder (appdata).
If the above is true, copy the service.ini file from the local roaming administrator folder into the folder of the user running the InfoBridge Service and try again
Path: C:\Users\[User]\AppData\Roaming\InfoBridge SuperOffice Exchange Synchronizer EWS