System Requirements - Exchange Online Synchronizer (EWS)

Last update:
Created :
Written by Support InfoBridge

To use the Exchange Online Synchronizer for SuperOffice CRM the following requirements have to be met.

Operating system:

  • Microsoft Vista Business
  • Microsoft Vista Ultimate
  • Microsoft Windows 7
  • Microsoft Windows 8
  • Microsoft Windows Server 2008 R2 (32 or 64-bit)
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2016

Database platforms:

  • Microsoft SQL Server 2005
  • Microsoft SQL Server 2008
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2014
  • Oracle 10.x, 11.x, 12.x

SuperOffice versions: 

  • SuperOffice CRM Win / Web 7.0.x
  • SuperOffice CRM Win / Web 7.1.x
  • SuperOffice CRM Win / Web 7.5.x
  • SuperOffice CRM Win / Web 8.0.x
  • SuperOffice CRM Win / Web 8.1.x
  • SuperOffice CRM Win / Web 8.2.x
  • SuperOffice CRM Win / Web 8.3.x
  • SuperOffice CRM Win / Web 8.4.x

Detailed checklists available here

Microsoft Exchange:

  • Microsoft Exchange 2010 (SP2 or higher)
  • Microsoft Exchange 2013
  • Microsoft Exchange 2016
  • Hosted Microsoft Exchange 2010 (SP2 or higher)
  • Microsoft Exchange Online (Office 365) More info 

Microsoft Outlook:

  • Microsoft Outlook 2007 (no .PST file support*)
  • Microsoft Outlook 2010 (no .PST file support*)
  • Microsoft Outlook 2013
  • Microsoft Outlook 2016
  • Microsoft Outlook 365

SuperOffice Windows client:

The Synchronizer is updated to be able to run without a SuperOffice Win client. This applies to version 3.2.262 and higher. More info

NOTE: Only available for SuperOffice 8.3 R1 and higher

For older versions of the Synchronizer server we need the SuperOffice Windows client installed, as the Synchronizer uses some shared components for logging into the SuperOffice Database. This implies a working ODBC connection to the SuperOffice Database and modify/write access to the SO_ARC folder.

  • SuperOffice Windows client v7.0.x
  • SuperOffice Windows client v7.1.x
  • SuperOffice Windows client v7.5.x
  • SuperOffice Windows client v8.0.x
  • SuperOffice Windows client v8.1.x
  • SuperOffice Windows client v8.2.x
  • SuperOffice Windows client v8.3.x
  • SuperOffice Windows client v8.4.x

NOTE: Office 365 Home, Personal and regular Business plans are not supported, as these plans do not have the Exchange Online component. Compare the Office 365 Business plans here.

Time Zones:

Times Zone support will be handled by the server where the Synchronizer service is installed. When more than 1 Time Zone needs to be Synchronized you will need to install a seperate Synchronizer instance for each Time Zone.

Prerequisites:

Please check your machine if all the prerequisites below are installed (see below).

If not installed, the installer will install the prerequisites automatically.

NOTE: The Exchange Online Synchronizer doesn't use MAPI anymore.